System Requirements

Go Button 3.2 requires an iPad, iPhone, or iPod touch running iOS 10.3 or newer:

  • iPad Pro or iPad Air (all models)
  • iPad (4th generation) or newer
  • iPad mini 2 or newer
  • iPhone 5 or newer
  • iPod touch (6th generation) or newer

Still have a question?

Our support team is always happy to help.

Business Hours
M-F 9am-7pm (ET)
Current time at our headquarters
04:03 PM